Slow Verification Throughput

Incident Report for Verifiable

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 18:34 CDT

Update

Resolved - All Systems Operational
All metrics and functionality are normal on our end, and our cloud provider (AWS) has cleared their incident. We’re marking our platform as fully operational and closing this incident.
Posted Oct 20, 2025 - 18:33 CDT

Update

Monitoring - Performance Update
All systems are operational, though we’re still observing slightly elevated latency. The platform is functioning near normal capacity, and our team will continue to monitor performance closely and update when applicable.
Posted Oct 20, 2025 - 15:21 CDT

Update

We are still experiencing issues with our cloud provider. To safeguard data integrity, we have temporarily paused verifications and background actions. All requests will continue to be accepted and queued for processing once services are re-enabled. During this period, you may notice slower performance. We will share updates as more information becomes available.
Posted Oct 20, 2025 - 13:05 CDT

Update

We have received reports of general slowness in the application. All systems are operational but currently experiencing degraded performance. We are monitoring the situation closely and will provide updates as more information becomes available.
Posted Oct 20, 2025 - 10:26 CDT

Monitoring

We are currently experiencing performance degradation due to ongoing issues at our cloud provider. As a result, verifications may take longer than usual to complete. When starting a verification, you may see a message stating it can take up to 24 hours. In most cases, processing will be faster, but delays are possible until the underlying issue is resolved.
Posted Oct 20, 2025 - 10:02 CDT
This incident affected: Platform API and Env: Staging (Platform API).